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Visualization: Basics of
Rendering in AutoCAD
2009

This tutorial outlines the procedures on how to use 3D commands and tools to render a 3D
model such as render presets, views, and illumination.

NOTE This tutorial is a prerequisite for all the visualization tutorials.

Audience: Users new to rendering and 3D workflow in AutoCAD

Prerequisites:  Working knowledge of 3D Modeling

Time to complete: 45 minutes
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Usage Scenario
The final goal of creating a 3D model is to communicate an idea graphically.
You can output a model by creating and saving a rendering as an image file
for future display.

A rendered image is like a photograph, the following table outlines the
similarities between creating a rendered image and taking a photograph:

To create a rendered image you
need:

To take a photograph you need:

3D modelsubject model or scene

Enable calculation of lighting in the 3D
model

right illumination

named view or a cameraa camera

a backgrounda background or a location

To create rendered images of varying quality in AutoCAD o a 3D model, you
can:

■ Save and restore a named view in different viewports

■ Modify the view

■ Define a background

■ Create a lighting environment.

■ Display a shaded 3D model in a viewport

■ Specify a render preset

■ Modify the render exposure setting to generate renders of varying quality
You can access all the tools previously mentioned as well as other 3D
related tools from the ribbon in the 3D Modeling workspace.
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Features covered in this tutorial:

1 Explore the 3D Modeling workspace

2 Explore the ribbon panels related to 3D modeling and rendering

3 Enable hardware acceleration

4 Create and restore named views

5 Enable sky background and illumination

6 Enable shadow display

7 Use render presets

8 Modify the rendered exposure

Tutorial Files
All the necessary files for this tutorial are located at
http://www.autodesk.com/autocad-tutorials.

Recommended

Before starting the tutorial:

1 Download the vis_basics_rendering.zip file from
http://www.autodesk.com/autocad-tutorials.

2 Unzip the vis_basics_rendering.zip file to C:\My Documents\tutorials.

In This Tutorial

■ Lesson 1: Set up a 3D environment on page 4

■ Lesson 2: Save and Restore Views  on page 9

■ Lesson 3: Use Sky Background with Illumination on page 20

■ Lesson 4: Render Presets on page 24

Features covered in this tutorial: | 3



Lesson 1: Set up a 3D environment
In this lesson, you will learn how to set a 3D Modeling workspace current, to
enable hardware acceleration and how to display multiple views of a model.

File Name: rendering.dwg

Command Entry: WORKSPACE, RIBBON,STEERINGWHEEL, 3DCONFIG, VIEWPORTS

When you switch to the 3D Modeling workspace, the ribbon displays tools
used for 3D modeling and rendering.

The tools used in this tutorial are on the ribbon’s Home, View, and Output
tabs.

To open the drawing

1 Click Start menu (Windows) ➤ Programs ➤ Autodesk ➤ AutoCAD
2009 ➤ AutoCAD 2009.

2 Click  ➤ File ➤ Open

3 Navigate to C:\My Documents\Tutorials. Open the rendering.dwg file.
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To set the 3D Modeling workspace current

1 Click  ➤ Tools ➤ Workspaces ➤ 3D Modeling.

NOTE Alternatively, on the status bar, click Workspace Switching and select

3D Modeling from the workspaces list. 

To explore the ribbon in the 3D Modeling Workspace

In the 3D Modeling workspace, the ribbon displays all tools for 3D modeling.

1 On the ribbon, click and explore the following tabs:

■ Home: This tab contains the tools for creating, modifying, and viewing
3D models. For this tutorial, you will work with the View panel.

■ Visualize: This tab contains tools to help you enhance the visual
appearance of the model, such as materials, lights and visual styles.
For this tutorial you will work with the Visual Styles, Lights, Sun, and
Time & Location panels.
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■ View: This tab contains controls to view the model, such as the
number of viewports and the current coordinate system. It also
contains tools to display more palettes and windows elements. For
this tutorial, you will work with the Viewports panel.

■ Output: This tab contains panels with all the tools and controls to
output a 3D model into several formats such as: a rendered image, a
plotted drawing, or a file to be exported to another application. For
this tutorial, you will work with the Render panel.

NOTE For more information on the ribbon, see the AutoCAD User's Guide.

To enable hardware acceleration

The performance and stability of the new 3D display features in AutoCAD
2009 depends on the capabilities of your graphics hardware. Ensure that the
Hardware Acceleration and the new 3D display features are enabled in the
Manual Performance tuning for optimal performance.

1 On the ribbon, click the Visualize tab ➤ Visual Styles ➤  Performance
Tuner.
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2 In the Adaptive Degradation and Performance Tuning Dialog box, click
Manual Tune.

3 In the Manual Performance Tuning, under Hardware Settings, select
Enable Hardware Acceleration.

4 In the Driver name drop-down list, select Direct 3D.

5 In the Current Effect Status list, ensure that Full-Shadow Display is on.

NOTE If hardware acceleration is unavailable or if you experience performance
problems when working in 3D, it is recommended to install the latest video
graphics card driver available for your system. To install the latest driver, visit
the video card manufacturer's website or the AutoCAD Certification website
at http://www.autodesk.com/autocad-graphicscard.
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To display multiple views in model space

When you work with 3D models you should set up a top, front and isometric
view of a model. To display these views, split the drawing area into different
model space viewports. As you make a change in one viewport, the other
viewports also update.

1 On the ribbon, click the View tab ➤ Viewports panel ➤ New 

2 In the Viewports dialog box, New Viewports tab, New Name field, enter
3D Viewports.

3 In the Standard Viewports list, select Three: Left.

4 In the Apply To drop-down list, select Display.

5 In the Setup drop-down list, select 3D.

6 Click OK to close the Viewports dialog box.

7
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In the next lesson, you will configure each viewport to display a different
view of the model.

8 Click  ➤ File ➤ Save

Next Lesson: Lesson 2: Save and Restore Views  on page 9

Lesson 2: Save and Restore Views

In this lesson, you will learn how to modify, save and restore different views
of a model in order to display them in different viewports.
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File Name: rendering.dwg

Command Entry: VIEW, NAVVCUBE, STEERINGWHEELS

You can create different model views of the model, each view will help you
work with 3D models and rendered images. You can specify different settings
for each view, such as the background, visual style and coordinate system.
You can save and later restore the view to different viewports for rendering
and also switch between views. Using visual styles in different viewports, you
can display a model in a hidden, conceptual, wireframe, or realistic view.
Different visual styles provide you with different information about a 3D
model.

To specify a visual style for a viewport

1 Click inside the left viewport to make it current.

2 On the ribbon, click the Home tab ➤ View panel. In the Visual Styles
drop-down list, select Conceptual.

This visual style uses cool and warm colors to enhance the appearance
of the faces that could be difficult to see in other visual styles.

To adjust the view

1 On the ribbon, click the Home tab ➤ View panel ➤ SteeringWheels

2 Use orbit, pan, and zoom tools to adjust the view as it is displayed in the
following illustration.
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3 To close the wheel, press ESC or ENTER

NOTE For more information on SteeringWheels, see the AutoCAD User's
Guide or refer to Navigating a Model with SteeringWheels in AutoCAD 2009
tutorial at http://www.autodesk.com/autocad-tutorials.

To specify a background for a view

1 At the Command prompt, enter background.

2 Select Sun & Sky from the Type drop-down list.

3 In the Adjust Sun & Sky dialog box, under General, in the Status
drop-down list, select On.
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4 Click OK to close the Background dialog box.

NOTE The background appearance depends on the angle of the sun. If this
is the first time you specify a background, the angle is calculated by default
according to the computer clock settings for date, time and location. In the
next lesson you will modify the angle of the sun.

The left viewport has a sun and sky background defined. You can use
this view for rendering output, which you will do in the final lesson in
this tutorial.
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To save a named view

1 On the ribbon, click the Home tab ➤ View panel. In the View drop-down
list, select New View.

2 In the New View/Shot Properties dialog box, in the View Name field,
enter MyView.
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3 In the View Properties tab, under Boundary, click Current display.

4 Under settings, in the UCS drop-down list select, World

5 In the Visual style drop-down list, select Current.

6 Under Background, select Sun & Sky from the drop-down list.

7 In the Adjust Sun & Sky Background dialog box, Under General, ensure
that Status is turned on.
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8 Click OK to close the Adjust Sun & Sky Background dialog box.

9 Click OK to close the New View / Shot Properties dialog box.

To modifying the view for the upper-right viewport

1 Click inside the upper-right viewport.

2 On the ribbon, click the Home tab ➤ View panel. In the Visual Styles
drop-down list, select 2D Wireframe.

2D Wireframe is the default visual style when working in 2D. Objects in
this visual style display as lines and curves.

In this viewport, it is convenient to display a top view to have information
about the location of all the objects of the model. You can select this
view from a list of predefined 3D views by doing the following.

3 On the ribbon, click the Home tab ➤ View panel. In the View drop-down
list, select Top.

NOTE You can restore views that you previously saved in a drawing using
the View drop-down list.

4 On the ribbon, click the Home tab ➤ View panel ➤ SteeringWheels

5 Use orbit, pan, and zoom tools to adjust the view as it is displayed in the
following illustration.
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TIP You can also right-click inside the viewport and click SteeringWheels.

To modify the view of the lower-right viewport

1 Click inside the lower-right viewport.

2 On the ribbon, click the Home tab ➤ View panel. In the Visual Styles
drop-down list, select 3D Hidden.

The 3D Hidden visual style displays the objects as wireframe but hides
all lines representing the back faces.

When you select a visual style other than 2D Wireframe, the ViewCube
is displayed. The ViewCube provides visual feedback about the model’s
orientation of the model. You can quickly adjust the view of the model
by clicking one of the predefined areas.

NOTE If the ViewCube is not is not visible, on the ribbon, click the Home
tab ➤ View panel ➤ ViewCube display.

3 Click the Home icon located near the ViewCube. A default view of the
model is restore.
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4 On the UCS menu located below the ViewCube, click the down arrow,
select WCS from the list.

NOTE For more information on ViewCube, see the AutoCAD User's Guide
and Navigating a Model with ViewCube in AutoCAD 2009 tutorial at
http://www.autodesk.com/autocad-tutorials.

5 On the ViewCube, click RIGHT.

To define a background for the view

6 At the Command prompt, enter background.

7 In the Background dialog box, in the Type drop-down list, select Solid.

8 Under Solid options, click inside the color box.
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9 In the Select Color dialog box, Index tab, in the Color field enter 255.

10 Click OK to close the Select Color dialog box.

11 Click OK to close the Background dialog box.
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To change to a perspective projection

12 Right-click the ViewCube and click Perspective. The 3D model is displayed
with a perspective projection.

With this type of projection, you see more details such as the depth of
the objects.

13 On the ribbon, click the Home tab ➤ View panel ➤ SteeringWheels

14 Use the SteeringWheel to zoom in and adjust the view as it is displayed
in the following illustration.

Now each viewport displays different views with different visual styles,
allowing you to view different details about the 3D model.
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15 Click  ➤ File ➤ Save

Next Lesson: Lesson 3: Use Sky Background with Illumination on page 20

Lesson 3: Use Sky Background with
Illumination

In this lesson, you will add light to a 3D model using the Sky Background
with Illumination feature to simulate the effect of light scattered by the
atmosphere on the model.

File Name: rendering.dwg,

Command Entry: GEOGRAPHICLOCATION, SUNPROPERTIES

Sun and Sky feature simulates light cast from the atmosphere and sun. You
can control the angle of the light by changing the date and time for the 3D
Model. You can display the shadows created by the model in the viewport for
a better sense of depth.
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To enable Sky Background with Illumination

In the previous lesson, you assigned the sun and sky as the model’s
background. Now you will enable the calculation of the extra light in the 3D
model.

1 Click inside the left viewport to make it current.

2 On the ribbon, click Visualize tab ➤ Sun panel. Ensure that Sun Status is
enabled.

If not, on the ribbon, click Visualize tab ➤ Sun panel.

NOTE If the Lighting - Viewport Lighting Mode dialog box appears, click
Turn off the default lighting.

3 On the ribbon, click Visualize tab ➤ Sun panel. In the Sky drop-down
list, select Sky Background with Illumination.

To enable shadows

For a better sense of depth when you modify a 3D model, you can display
shadows before generating a rendered image in the current viewport.

1 On the ribbon, click the Home tab ➤ Layers panel. In the Layer control
drop-down list, turn on layer Floor.

layer control drop-down list
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A plane representing the ground of the 3D model is displayed.

2 On the ribbon, click the Visualize tab ➤ Lights panel. In the Shadows
drop-down list, select Full Shadows.

Now the shadows of the model are displayed in the current viewport.

To define time and location of a model

The angle of light from the sun is controlled by the geographic location,
AutoCAD sets the time and location accordingly.

1 On the ribbon, click the Visualize tab ➤ Time & Location

panel ➤ Location 

2 In the define Geographic Location dialog box, click Enter the Location
Values.

3 In the Geographic Location dialog box, click Use Map.
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4 In the Location Picker dialog box, click over the area that represents
Mexico. Click OK.

NOTE If the Geographic Location - Time Zone Updated appears, click Accept
updated time zone.

5 In the Geographic Location dialog box, Under North direction, drag the
compass needle to specify an angle of 45 degrees. Click OK.

6 On the ribbon, click the Visualize tab ➤ Time & Location panel and drag
the Sun date slider to specify 3/4/2008 as the current date.
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7 Drag the Sun time slider to specify 8:00 AM as the current time.

As you move the slider, you will see the changes displayed in the current
viewport.

8 Click  ➤ File ➤ Save

Next Lesson: Lesson 4: Render Presets on page 24

Lesson 4: Render Presets
In this lesson, you will create rendered images of varying quality by using
different render presets and modifying the render exposure.

File Name: rendering.dwg

Command Entry: RPREF

1 With Render Presets, you can:

Create renders of varying quality without manually specifying individual
properties.

2 Reuse rendering parameters to create rendered images with the same
settings after modifying the 3D model.

To generate a rendering with draft image quality

With the draft render preset, you can create a quick image of the 3D model
to analyze its conceptual details.

1 On the ribbon, click the Output tab ➤ Render panel ➤ and select Draft
from the Render Presets drop-down list.
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2 On the ribbon, click the Output tab ➤ Render panel ➤ Render 

In the Render Window, you can view:

■ The render progress

■ The history of the files rendered

■ Information about the settings used to create the rendered image.

The Progress Meter gives you a visual estimate of how much information
is left to be processed.

3 When the render is complete, click File menu ➤ Save.

4 In the Render Output File dialog box, navigate to C:\My
Documents\Tutorials.

5 In the File Name field, enter draft_quality_render.

6 In the type drop-down list, select JPG. Click Save.
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To generate a rendering with high image quality

You can create a High quality rendered image, besides selecting a High quality
Render Preset, adjust the Rendered Exposure in order to specify the amount
of light computed. This adjustment is like adjusting a camera's exposure before
taking a photograph, you adjust the exposure accordingly to the lighting
conditions.

To adjusting the Rendered Exposure

1 On the ribbon, click the Output tab ➤ Render panel ➤ Adjust Exposure.

2 In the Adjust Rendered exposure dialog box, under Adjust Rendered
Exposure:

■ In the Brightness drop-down list, select 45

■ In the Contrast drop-down list, select 50

■ In the Mid tones drop-down list, select 4

■ In the Exterior Daylight drop-down list, select On

■ In the Process Background drop-down list, select On.Click OK.
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3 On the ribbon, click the Output tab ➤ Render panel. In the Render Presets
drop-down list, select High.

Specifying location, type, and size for the rendered image

1 On the ribbon, click the Output tab ➤ Render panel ➤  . Click the
push pin to pin the panel. You can to modify all the necessary options
without expanding the Render panel each time want to change the render
output.

2 Click Save the Rendering to a File.
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3 Click the Browse button [...].

4 Navigate to C:\My Documents\Tutorials.

5 In the File Name field enter high_quality_render.

6 Select JPEG from the File type drop-down list. Click Save.

7 In the JPEG Image Options dialog box, under Image Control, drag the
Quality and File Size sliders to the right. Click OK.

The renders that you create from now on will be saved with the name
high_quility_render.jpg inside the specified folder.

8 On the ribbon, click the Output tab ➤ Render panel. In the Output size
drop-down list, select 1024X 768.
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9 On the ribbon, click the Output tab ➤ Render panel ➤ Render 

10 In the Render Window, once the render is complete, click File menu ➤ 

Exit to close the window. The file is saved in the previously specified
folder.

11 In the Windows Explorer, navigate to C:\My Documents\Tutorials.

12 Open the file high_quality_render.jpg.
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You can use this image for presentation purposes.

Summary: AutoCAD offers many tools for working with 3D models and
rendering. With AutoCAD, you can:

■ Set the 3D Modeling workspace current to display all the tools relevant to
3D

■ Explore the ribbon to become familiar with the locations of many of the
commonly used tools for working with a 3D model.

■ Modify a view using navigation tools such as SteeringWheels and the
ViewCube

■ Specify a visual style for the current view and saved it for future use

■ Specify and restored saved views to different viewports.

■ Enable light generated by the sun and sky.

■ Enable shadows generated by Sun & Sky Illumination feature

■ Modify the angle of the sun by defining date, time, and location for the
3D model
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■ Use render presets to generate rendered images of varying quality.

■ Save the rendered output to a JPEG file format for future display

For more information, see the AutoCAD’s 2009 User's Guide.

Congratulations! You have used 3D commands and tools to render a 3D model
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